Delay with USDC deposits via wire

Incident Report for VALR

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 09:44 SAST

Update

USDC deposits via wire are now resolved for new deposits. Deposits received between Thursday 20 March 2025 and Tuesday 25 March 2025 are still delayed in allocation and will be credited ASAP.
Posted Mar 26, 2025 - 09:35 SAST

Identified

USDC deposits via wire are currently experiencing delays due to technical issues with Circle's receiving bank. We are working with all parties to restore deposits as soon as possible.
Posted Mar 25, 2025 - 11:12 SAST