Database maintenance

Incident Report for VALR

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 10:50 SAST

Investigating

We are undergoing database maintenance, certain transactional records will be delayed until maintenance is concluded.
Posted Oct 08, 2025 - 09:57 SAST
This incident affected: API and VALR.COM.