Email delivery issue

Incident Report for VALR

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 14:34 SAST

Investigating

We are currently investigating this issue.
Posted Aug 15, 2025 - 11:14 SAST