Credit card deposits on the Visa network using Checkout are currently not available for certain countries. If you reside in Germany or Namibia you might be impacted.

Incident Report for VALR

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 03, 2026 - 16:26 SAST

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 16:26 SAST